我连接到VPN服务器,它需要通过
/usr/sbin/openvpn --config /etc/openvpn/server.ovpn这提示我输入登录/密码(= OK)。
我将登录名和密码添加到一个文件中,并将/etc/openvpn/server.ovpn配置更新为
auth-user-pass /etc/openvpn/auth.txt我不再被提示输入密码。
我希望从命令行提供身份验证凭据,而不是从配置文件中获取它们:
/usr/sbin/openvpn --auth-user-pass /etc/openvpn/auth.txt --config /etc/openvpn/server.ovpn凭据文件以及配置(除了上次测试中删除的auth-user-pass行外)都是相同的。
OpenVPN版本是2.3.10,它是用enable_password_save=yes编译的(这必须是因为通过配置文件提供凭据,所以包是从标准的Ubuntu存储库安装的)
发布于 2016-12-02 16:21:46
显然,您的OpenVPN用户能够访问auth文件(否则从配置文件中引用就会失败)。
但是要确定的是:启动OpenVPN连接的用户是否允许读取它?
https://serverfault.com/questions/818345
复制相似问题