我最近升级了我的VPS到一个4核,8gb内存和180 8gb的ssd。该VPS配备500个免费电子邮件帐户,每个2gb。这个周末,我将从旧的VPS迁移到这个新的VPS的所有内容,所以我将重新创建所有的电子邮件帐户,等等,我现在质疑自己是否应该继续使用免费的电子邮件帐户或使用VPS作为邮件服务器,我想拥有我自己的邮件服务器的唯一原因是因为我想用DKIM和SPF来验证我的电子邮件,因为它们中的一些正在使用垃圾邮件--我相信这将提高发送速率。所以我的问题是,如果我能够访问域的DNS,是否可以验证那些免费帐户DKIM和SPF,请注意,我对所有这些电子邮件都没有控制权,我唯一的控制是我可以创建和删除帐户,但我的意思是我不能对邮件服务器进行控制台访问或任何事情。对于您的上下文,VPS有1和1,还有免费帐户。
请注意,我没有使用邮件服务器和DNS的经验,我是php开发人员。
发布于 2016-10-05 14:07:06
似乎你现在不能做DKIM (或者这对你来说很难),所以最好也避免防晒。
如果你想要SPF条目在DNS,我强烈建议也有DMARC条目和DKIM条目。
原因如下:互联网上的许多人使用转发地址。他们设置了peter@example.com,但自动将其转发给peter1939@gmail.com。如果您只有SPF,有效地从您的服务器上的邮件无法到达他们。如果你有DKIM,邮件就会通过。
DMARC是一种策略机制,如果消息成功,则接受SPF失败的消息,如果消息成功,还需要检查发送方地址是否不匹配,再加上与您域的子域相关的检查。松了口气。
DKIM是整个设置中最困难的部分。对于发送出去的电子邮件,它要求您在电子邮件中插入标题。因为1和1似乎还不能做到这一点,所以您需要建立自己的exim/sendmail。没有太多的细节,我想这可能是一个陡峭的学习曲线,如果你不试图成为一个熟练的电子邮件管理员。
https://serverfault.com/questions/807224
复制相似问题