我正在尝试使PPTP安装和运行在我的VPS上。我已经遵循了各种指南,然而,我无法连接到VPN一旦设置。
我检查了VPS的/var/log/messages,发现了这个:
1832 Dec 2 23:38:55 server9987 pptpd[1470]: CTRL: Client 86.8.79.197 control connection started
1833 Dec 2 23:38:55 server9987 pptpd[1470]: CTRL: Starting call (launching pppd, opening GRE)
1834 Dec 2 23:38:55 server9987 pppd[1471]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
1835 Dec 2 23:38:55 server9987 pppd[1471]: This system lacks kernel support for PPP. This could be because the PPP kernel module could not be loaded, or because PPP was not inc luded in the kernel configuration. If PPP was included as a module, try `/sbin/modprobe -v ppp'. If that fails, check that ppp.o exists in /lib/modules/`uname -r`/net. See README.linux file in the ppp distribution for more details.
1836 Dec 2 23:38:55 server9987 pptpd[1470]: GRE: read(fd=6,buffer=8059680,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termina tion of pppd, check option syntax and pppd logs
1837 Dec 2 23:38:55 server9987 pptpd[1470]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
1838 Dec 2 23:38:55 server9987 pptpd[1470]: CTRL: Client 86.8.79.197 control connection finished它说我的“系统缺乏对PPP的内核支持”。这是否造成问题的原因,若然,是否有解决办法?
发布于 2012-12-02 23:54:10
您几乎可以肯定地使用了基于OpenVZ的VPS。在这种情况下,主机必须为您启用ppp内核模块(以及您可能需要的任何其他模块)。与您的主机提供商一起打开支持票。
如果他们不能或不愿意为你做这个改变,买另一个不使用OpenVZ的VPS,这样你就可以选择自己的内核模块了。
https://serverfault.com/questions/454412
复制相似问题