我的MySQL服务没有启动。我在我的VPS中使用debian作为操作系统。我使用MyISAM存储表。
启动服务时的响应
root@ipxweb1:~# service mysql start
[FAIL] Starting MySQL database server: mysqld . . . . . . . . . . . . . . failed!当我使用mysqld命令时,会出现以下错误。
root@ipxweb1:~# mysqld
120811 22:06:39 [Warning] option 'thread_stack': unsigned value 65536 adjusted to 131072
120811 22:06:39 [Warning] ignore-builtin-innodb is deprecated and will be removed in future releases.
120811 22:06:39 [Note] Plugin 'FEDERATED' is disabled.
120811 22:06:39 [Note] Server hostname (bind-address): '(null)'; port: 3306
120811 22:06:39 [Note] - '(null)' resolves to '0.0.0.0';
120811 22:06:39 [Note] - '(null)' resolves to '::';
120811 22:06:39 [Note] Server socket created on IP: '0.0.0.0'.
120811 22:06:40 [ERROR] Fatal error: Can't open and lock privilege tables: Got error 5 from storage engine我正在运行一个负载平衡服务器,使用glusterfs进行复制。在两个服务器上复制/var/lib/mysql目录。第二台服务器上的MySQL启动非常好。它在第一台服务器上运行良好。一个晴朗的早晨,没有我的干预,事情发生了。
发布于 2012-08-11 18:37:01
$ perror 5
OS error code 5: Input/output error是时候检查你的磁盘了..。
但是,由于它是(很可能是租来的) VPS,所以您不能真正检查服务器的磁盘。您可能需要要求主机提供商调查它。
https://serverfault.com/questions/416575
复制相似问题