首页
学习
活动
专区
圈层
工具
发布
社区首页 >问答首页 >bower即使在添加决议之后也无法为jquery错误找到合适的版本

问bower即使在添加决议之后也无法为jquery错误找到合适的版本
EN

Stack Overflow用户
提问于 2017-03-06 06:13:08
回答 2查看 3.2K关注 0票数 1
代码语言:javascript
复制
"dependencies": { 
  "jquery": "~2.1.4", 
  "angular": "~1.5.0",
  ....
  ....
},
"resolutions": {
  "jquery": "~2.1.4",
  "angular": "~1.5.0"
}

保龄球安装角钢-保存

缓存https://github.com/projectweekend/angular-peity.git#0.0.5保龄球#*验证0.0.5对https://github.com/projectweekend/angular-peity.git#* peity#*缓存https://github.com/benpickles/peity.git#3.2.1保龄球peity#*验证3.2.1对https://github.com/benpickles/peity.git#*保龄球jquery#~2.0.3缓存https://github.com/jquery/jquery-dist.git#2.0.3保龄球jquery#~2.0.3验证2.0.3对抗https://github.com/jquery/jquery-dist.git#~2.0.3保龄球jquery#>=1.6缓存https://github.com/jquery/jquery-dist.git#3.1.1 bower jquery#>=1.6验证3.1.1针对https://github.com/jquery/jquery-dist.git#>=1.6 bower jquery#>=1.7缓存https://github.com/jquery/jquery-dist.git#3.1.1 bower jquery#>=1.7验证3.1.1针对https://github.com/jquery/jquery-dist.git#>=1.7 bower jquery#1.9.1 -3 cached https://github.com/jquery/jquery-dist.git#3.1.1 bower jquery#1.9.1 -3验证3.1.1针对https://github.com/jquery/jquery-dist.git#1.9.1 -3 bower jquery#>=1.4.4缓存https://github.com/jquery/jquery-dist.git#3.1.1 bower jquery#>=1.4.4验证3.1.1针对https://github.com/jquery/jquery-dist.git#>=1.4.4 bower jquery#^2.0.3缓存https://github.com/jquery/jquery-dist.git#2.2.4 bower jquery#^2.0.3验证2.2.4针对https://github.com/jquery/jquery-dist.git#^2.0.3 bower ECONFLICT无法找到适合jquery的版本

EN

回答 2

Stack Overflow用户

回答已采纳

发布于 2017-03-19 17:28:22

一开始最好的方法就是

代码语言:javascript
复制
bower cache clean

在那之后,当你做

bower install,它会问你

代码语言:javascript
复制
Unable to find a suitable version for jquery, please choose one:
1) jquery#exampleversion1 which resolved to 1.5.3 and is required by demo1
2) jquery#^exampleversion2 which resolved to 1.5.3 and is required by app2    
3) jquery#>.examplegversion3 which resolved to 1.5.3 and is required by app3Test

然后您可以输入!1或!2,或者任何最适合您需要的内容。

使用!前缀数字实质上增加了bower.json中的分辨率块,但它将使您更好地控制正在发生的事情,并且可能解决您的问题。

票数 3
EN

Stack Overflow用户

发布于 2017-08-24 12:20:13

在Windows 10上,Git中也出现了相同的错误

ECONFLICT无法为jquery找到合适的版本

而且我也不能选择!1或者!2

对我来说,切换到Windows解决了问题,运行了相同的命令bower install

我怀疑它与用户权限有关。

票数 2
EN
页面原文内容由Stack Overflow提供。腾讯云小微IT领域专用引擎提供翻译支持
原文链接:

https://stackoverflow.com/questions/42618699

复制
相关文章

相似问题

领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档