首页
学习
活动
专区
圈层
工具
发布
社区首页 >问答首页 >码头集装箱启动失败

问码头集装箱启动失败
EN

Stack Overflow用户
提问于 2016-05-02 19:53:54
回答 2查看 2.5K关注 0票数 1

我有一个容器: 5.6.21-apache来自/php/

我已经安装了我所需要的所有程序和应用程序,但是我在Apache上做了一些错误。

当我尝试启动我的容器时,我会收到这样的消息:

码头启动-ai我的容器 02年5月19日:46:33.358838 2016年pid 1 AH00111:配置变量${APACHE_LOG_DIR}未定义Mon 02 19:46:33.365305 2016年pid 1 AH00111:配置变量${APACHE_LOG_DIR}未定义AH00558: apache2:无法可靠地确定服务器的完全限定域名,使用172.17.0.2。全局设置“ServerName”指令以抑制此消息(2)没有这样的文件或目录: AH02291:无法访问目录/etc/apache2/${APACHE_LOG_DIR}/‘用于主错误日志AH00014:配置检查失败

我怎么才能解决这个问题?我要放下这份秘密。我不能就这么丢了这个容器。

EN

回答 2

Stack Overflow用户

回答已采纳

发布于 2016-05-03 00:23:57

既然你没有给出足够的信息来继续,我就猜。请随意添加更多的信息到你的问题,这样它将更容易帮助你。

如果您搜索apache文件并查找APACHE_LOG_DIR,它可能会指向您的问题。

日志中的这一行很有趣:

无法访问目录'/etc/apache2/${APACHE_LOG_DIR}/‘

不确定为什么会在/etc/apache2下有一个日志目录,但请查看该目录中有哪些内容,并相应地设置APACHE_LOG_DIR。

您可以尝试的另一件事是执行以下操作

代码语言:javascript
复制
docker commit (container name or Id) myimage

docker run -it myimage /bin/bash

然后再次提交更改来创建固定的映像,并尝试像正常一样启动它。

代码语言:javascript
复制
docker commit (container Id or name) myimage2

docker run -d -p 80:80 myimage2

基本上,将当前容器状态保存为映像,这样您就可以在shell中启动它并修复问题。然后,一旦修复了这些问题,就可以创建一个新的映像,并使用它来运行容器。

我通常通过不直接在容器中进行更改来避免这种痛苦,我只在我的dockerfile中进行更改,然后当我需要进行更改时,我会更改dockerfile。如果有问题,我只需要修复dockerfile,容器就不会处于这种糟糕的状态。

票数 0
EN

Stack Overflow用户

发布于 2017-07-13 09:25:34

在我的情况下,在重新启动计算机(或休眠/重新启动系统)后,我在启动容器时遇到了问题。在运行start之前,我使用docker命令。示例:

代码语言:javascript
复制
docker exec -ti CONTAINER_NAME /bin/bash

(有一条消息表明容器没有运行,然后)

代码语言:javascript
复制
docker start CONTAINER_NAME
票数 0
EN
页面原文内容由Stack Overflow提供。腾讯云小微IT领域专用引擎提供翻译支持
原文链接:

https://stackoverflow.com/questions/36990594

复制
相关文章

相似问题

领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档