首页
学习
活动
专区
圈层
工具
发布
社区首页 >问答首页 >Debian 8 openvpn init脚本忽略配置文件

问Debian 8 openvpn init脚本忽略配置文件
EN

Stack Overflow用户
提问于 2016-04-18 01:22:59
回答 2查看 1.2K关注 0票数 0

当我使用“/etc/ openvpn”中的“openvpn server.conf”运行openvpn时,一切都很好。但是,当我运行'/etc/init.d/openvpn start‘或’etc/init.d/openvpn start server‘或'/etc/init.d/openvpn start server.conf’时,server.conf configfile将被忽略。为什么?

希望有人能帮我。

致以问候。

EN

回答 2

Stack Overflow用户

回答已采纳

发布于 2016-04-22 12:43:35

最后我找到了解决办法。而不是使用/etc/init.d/openvpn restart,您可以使用

service openvpn restart或

systemctl restart openvpn.service

启动/停止/重新启动/重新加载服务。https://stackoverflow.com/a/28930361/6217547带领我找到了这个解决方案。

票数 0
EN

Stack Overflow用户

发布于 2016-04-18 10:42:02

首先要检查的是systemd状态(如果我正确的话,Debian 8与systemd一起运行)。

所以您可以这样做:systemctl状态openvpn并检查输出。

  1. Active: active (运行) =>在这里没有多大帮助
  2. 活动:活动(退出) =>它已经正确启动并退出,没有错误,常见的原因可能是没有找到配置文件。
  3. 活动:失败(结果:退出代码) =>它已经启动并且失败了。THen您可以执行一个日志-xe并检查消息。

让我们知道结果。

票数 0
EN
页面原文内容由Stack Overflow提供。腾讯云小微IT领域专用引擎提供翻译支持
原文链接:

https://stackoverflow.com/questions/36684083

复制
相关文章

相似问题

领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档